Twój serwer korzysta z PHP w wersji 4.3.10, lecz WordPress 3.8.1 wymaga co najmniej wersji 5.2.4.